Support Center

ViMP Support

Support-Forum

 
Avatar
ianj
Beiträge:
Hi can anyone advise why i keep getting the following error

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 44 bytes) in /var/www/vimp/data/lib/symfony/plugins/sfPropelPlugin/lib/vendor/propel-generator/classes/propel/engine/database/model/XMLElement.php on line 68

when executing ./symfony framework:init mysql://admin:<adminpassword>@localhost/showvid

i have changed the php memory limit in both the php.ini and cli and still getting the same error, the task starts and gets as far as

propel > om-template:

[propel-om] Processing: generated-45_favorites_schema.xml
[propel-om] Processing: generated-60_messsages_schema.xml
[propel-om] Processing: generated-70_channels_schema.xml
[propel-om] Processing: generated-30_users_schema.xml
[propel-om] Processing: generated-01_tags_schema.xml
[propel-om] Processing: generated-41_playlist_schema.xml
[propel-om] Processing: generated-10_roles_schema.xml
[propel-om] Processing: generated-99_other_schema.xml
[propel-om] Processing: generated-00_default_schema.xml
[propel-om] Processing: generated-20_categories_schema.xml
[propel-om] Processing: generated-98_i18n_schema.xml
[propel-om] Processing: generated-55_forums_schema.xml
[propel-om] Processing: generated-40_medias_schema.xml

then displays

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 44 bytes) in /var/www/media/data/lib/symfony/plugins/sfPropelPlugin/lib/vendor/propel-generator/classes/propel/engine/database/model/XMLElement.php on line 68

thanks
24.01.2012 17:56
Avatar
support
ViMP Support
Beiträge: 5544
Hello,

what´s your linux-distribution. Are you using any Server-Administration-Software like e.g. Plesk, confixx etc.?

How does your memory_limit entry look?
In a php.ini-file it has to look exactly like this:

iconCode:
memory_limit = 512M


You can set a higher value up to 2047M. Don´t forget the "=" and don´t set something like 512MB, or 512 or so.

Cheers,
ViMP Support Team
24.01.2012 23:35
Avatar
ianj
Beiträge:
Thanks for your swift response

i am on debian squeeze - i am using no server admin software

in my php.ini i have memory_limit = 1024M
i have tried changing this ranging between 64 1024

in my cli php.ini i have memory_limit = -1

thanks
[Zuletzt bearbeitet ianj, 25.01.2012 11:41]
25.01.2012 10:08
Avatar
ianj
Beiträge:
could it be this is on a test local box with only 1 gig of ram?
26.01.2012 11:40
Avatar
support
ViMP Support
Beiträge: 5544
Hello ianj,

please set in php.ini for cli:

memory_limit = 1024M

, too. I don´t know why, but -1 seems not to work here. I always change this.

Cheers,
ViMP Support Team
28.01.2012 02:02
Avatar
ianj
Beiträge:
after setting this i get the error

PHP Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 261900 bytes) in Unknown on line 0
Could not startup.
30.01.2012 11:14
Avatar
support
ViMP Support
Beiträge: 5544
Hello ianj,

Then I´m pretty sure your Server is too small.
http://www.vimp.com/en/documentation-faq-article/items/what-are-the-technical-requirements-for-vimp.html

You are sure, you´ve set the correct memory_limit in /etc/php5/cli/php.ini ?

But if you have a vServer with 1GB RAM, it´s very small.
But in regular it´s possible to install with 1 GB RAM.

Regards,
ViMP Support Team
06.02.2012 23:27
 

Loggen Sie sich ein oder registrieren Sie sich, um Forenbeiträge zu verfassen.

Anfrage
Anfrage
Demo