Support Center

ViMP Support

FAQ Installation and First steps

How to perform an update/upgrade (ViMP 2.6 and later)?

Editions: Community, Professional, Enterprise, Enterprise Ultimate, Corporate
Versions: 2.6.0+

This HowTo describes, how to update your current ViMP installation to the latest version (also applies for upgrades e.g. from ViMP Community to ViMP Professional), including all installed modules.

Always BACKUP your files and database before performing an update!
This article describes how to create a backup.

ViMP update packages have the following nomenclature:
vimp.framework-<version>-<edition>-updater.bin

ViMP module update packages have the following nomenclature:
vimp.module.<modulname>-<version>-updater.bin

In our example, we will update ViMP 2.5.13 including the module YouTube Import to ViMP 2.6.0.
In case your current ViMP version is >= 2.x, just follow the example exactly. There's nothing more you have to consider. The updater installs all changes of previous versions, even if you skip one or more version numbers.

First upload the udpate packages into the ViMP installation folder of your server, e.g. via SFTP or FTP.

Then log in to the shell as root (e.g. with putty) and change to the ViMP folder and grant execute permissions to the update packages:

cd /var/www
chmod +x vimp.*-updater.bin

Clear the ViMP/symfony Cache:

./symfony cc

Next, execute the update script:

./vimp.framework-2.6.0-r20671-community-updater.bin

You'll be prompted to enter or confirm the installation path. Default value is the current folder and is written in square brackets [...].

Install path [/var/www]:

Just hit Return, if you want to confirm the pre-filled value.

The updater checks the system requirements:

Starting Installer ...
>> OK        PHP version is at least 5.2.7 (5.3.3-7+squeeze14)
>> OK        PHP version is not 5.2.9
>> OK        DOM extension is installed
>> OK        XML extension is installed
>> OK        XSL extension is installed
>> OK        Tokenizer extension is installed
>> OK        Multibyte String extension is installed
>> OK        iconv extension is installed
>> OK        Posix extension is installed
>> OK        GD extension is installed
>> OK        cUrl extension is installed
>> OK        mysql extension is installed
>> OK        mcrypt extension is installed
>> OK        PDO is installed
>> OK        PDO mysql driver is installed
>> INFO      PDO has some drivers installed: mysql
>> INFO      No database information set
>> OK        SourceGuardian extension is installed
>> WARNING   Set short_open_tag to off in php.ini
>> OK        php.ini has magic_quotes_gpc set to off
>> OK        php.ini has register_globals set to off
>> OK        php.ini has safe_mode set to off
>> OK        php.ini has session.auto_start set to off
>> OK        php.ini has file_uploads set to on
>> OK        php.ini has allow_url_fopen set to on
>> OK        php.ini has register_argc_argv set to on
>> OK        php.ini has set memory_limit not equal to -1
>> OK        php.ini has set memory_limit greater or equal than 512M
>> OK        php.ini has set memory_limit lesser than 2G
>> OK        php.ini has set post_max_size greater or equal than 100M
>> OK        php.ini has set post_max_size lesser than 2G
>> OK        php.ini has set upload_max_filesize greater or equal than 100M
>> OK        php.ini has set upload_max_filesize lesser than 2G
>> OK        mplayer is installed
>> OK        mencoder is installed
>> OK        ffmpeg is installed
>> OK        flvtool2 is installed
>> OK        qt-faststart is installed
>> INFO      Version: dev (r20664)
>> INFO      Edition: COMMUNITY
>> INFO      OS: Linux 2.6.32-5-amd64 #1 SMP Mon Feb 25 00:26:11 UTC 2013
>> INFO      Memory: 2PB
 Continue? [Y/n]:

As we're updating a running ViMP platform, no ERROR messages should be expected. Confirm with Return to continue.

Now, the new files will be extracted from the package. The updater compares the given database tables with the new ones and always asks you to confirm changes.

...
>> update    Table channel_user changed
>> update    Table config changed
>> update    Table menu changed
>> update    Table role_permission changed
 Changes for Database found. Apply? [Y/n]:

Enter Y or press Return to apply the database changes. In case you didn't create a database backup yet, this is the last chance to abort and save your current database.

...
>> update    Changing table category...
>> update    Check filesystem for changes
>> update    File /data/sql/updates.sql changed
>> update    File /data/sql/upgrade.sql changed
 Changes for filesystem found. Apply? [Y/n]:

Confirm once again and the update of the framework will be executed.

...
>> file-     /var/www/data/frontend_dev-cli.lck

root@debian-6-64:/var/www/#

If you don't have any modules to update, you're done here.
In our example, we'll also update the YouTube Import module.
Proceed accordingly for all other installed modules.


Execute the update script of the module:

./vimp.module.youtubeimport-2.6.0-r20671-updater.bin

Again, you're asked to enter or confirm the installation path:

Install path [/var/www]:

Press Return to confirm.

...
>> file-     /var/www/data/frontend_dev-cli.lck

root@debian-6-64:/var/www/#

In our example, we're done now. Update the rest of your modules, if installed, to finish your ViMP update.

Last update on 2014/07/03 by Admin.

Go back

 

Inquiry
Inquiry
Demo