Support Center

ViMP Support

Support Forum

 
Avatar
trainingday
Posts: 3
Hello,

I have tried for 14 hrs(mostly learning linux) to install vimp and desperately need help. I have a vps with Debian 64bit. I have read multiple answers on the forum to this question but none fix it for me. Here is what I come up with. I have uploaded a file phpinfo.php to my vimp folder and it shows I have PHP Version 5.3.14-1~dotdeb.0. Now when I type into the shell "php -v" it shows I have Php Version 5.2.17 (cli). I cant figure that out yet. So next I found a command that you can type: find /-name php.ini well I changed everyone of those files extension_dir and still error. When I run php -m | grep -i guardian to see if sourceguardian is installed nothing happens just a new line(no output). So next I went here: http://www.sourceguardian.com/loaders/download.php and I followed the instructions there exactly even modified every php.ini with extension=ixed.5.3.lin ,but still nothing. I dont know what to do next to figure this out. I have 4 websites thats will be using vimp and I am still stuck on this one. On one forum thread "support" said I need sourceguardian for php5-cli but nothing on google shows help with that statement. Please help thanks. The phpinfo address is: sterling5 dot net /phpinfo dot php
10.07.2012 08:08
Avatar
support
ViMP Support
Posts: 9257
Hello trainingday,

would be more easy to read, if you would create some paragraphs in your text :-)

I recommend to install ViMP with the "Getting Started"-guide at
iconCode:
http://www.vimp.com/en/getting-started.html


There you find the guide to install sourceguardian, too:
http://www.vimp.com/en/documentation-faq-article/items/installing-the-sourceguardian-php-extension-only-vimp-community-and-vimp-professional.html

Kind Regards,
ViMP Support Team
10.07.2012 12:52
Avatar
trainingday
Posts: 3
I did use the guide at that link. As stated I tried this all day and got to last step with syfony and have this error. Could you please provide other suggestions?

Also, there is a file called php-config that has my extension_dir in a diffrent spot and I changed it and it still does not work. That file also says my php version is 2. I tried to update my php5 multiple times and it stills says 2 with php-v ,but phpinfo.php shows 3.

The only step on the getting started guide I did not get was:
There are three little modifications neccessary in the Apache configuration.
Open the according file with an editor, e.g. joe:. I only see 3 changes: add web and change from none to all. Whats the 3rd commented step??

HELP please.
[Last edited by trainingday, 10.07.2012 15:12]
10.07.2012 15:07
Avatar
support
ViMP Support
Posts: 9257
Hello trainingday,

then you have to install sourceguardian for both, for php5-cli and php5 for apache.

Cheers,
ViMP Support Team
12.07.2012 15:04
Avatar
flomoto
Posts: 1
Allright, but what else can we do to install sourceguardian for both of them, regarding that there are already simlinks poiting toward ../conf.d in /etc/php5/cli/conf.d/ AND /etc/php5/apache2/conf.d/ , and sourceguardian.ini is in this directory ?

If it loads for one of them, so it loads for both.
09.02.2013 14:36
Avatar
support
ViMP Support
Posts: 9257
Hello flomoto,

is that an answer or a questions?

If it´s a question please update the ViMP-URL in your profile and describe the problem first, maybe in a new thread.

Cheers,
Kai
ViMP Support Team
18.02.2013 16:24
Avatar
mit_icts
Posts: 72
Hi trainingday,

I've had the same problem on Ubuntu 14.04 LTS. I know this is an old post, but it may help someone...

The module should be enabled for both CLI and Apache, I think, when we run php5enmod

sourceguardian was showing up when I ran phpinfo() from a web page.

The CLI installer couldn't find it though.

To get round the problem, I put in :

extension=ixed.5.5.lin

into my /etc/php5/cli/php.ini file.

Not sure why it's needed, but that worked...

(your version numbers may be different of course...)
18.08.2014 03:11
Avatar
support
ViMP Support
Posts: 9257
Hello mit_icts,

with a default Ubuntu 14.04 installation the sourceguardian.ini should be created under /etc/php5/mods-available/ .
Then
# php5enmod sourceguardian
creates the links that enable the module for both, the CLI and apache.

Regards,
Kai
ViMP Support Team
19.08.2014 12:24
Avatar
bbbbighead
Posts: 1
Hi,

I am using
Ubuntu 13.04
PHP 5.4.9

PHP 5.4.9-4ubuntu2.4 (cli) (built: Dec 12 2013 04:26:30)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

I also download sourceguardian from http://www.sourceguardian.com/loaders.html
put it into /usr/lib/php5/20100525+lfs/ixed.5.4.lin (linux i368 verion)
and set /etc/php5/conf.d/sourceguardian.ini

[sourceguardian]
zend_extension=/usr/lib/php5/20100525+lfs/ixed.5.4.lin

of course I do this step "php5enmod sourceguardian" and "/etc/init.d/apache2 restart"

However, when I try to install vimp, it shows the following error message.
================================
Failed loading /usr/lib/php5/20100525+lfs/ixed.5.4.lin: /usr/lib/php5/20100525+lfs/ixed.5.4.lin: wrong ELF class: ELFCLASS64
Failed loading /usr/lib/php5/20100525+lfs/ixed.5.4.lin: /usr/lib/php5/20100525+lfs/ixed.5.4.lin: wrong ELF class: ELFCLASS64

PHP Fatal error: Call to undefined function sg_load() in /home/xxxxx/vimp/vimp-3.1.1/config/ProjectConfiguration.class.php on line 2
================================

Please help. I spent lots of time doing this but failed.
21.09.2014 19:32
Avatar
support
ViMP Support
Posts: 9257
Hello bbbbighead,

I´m pretty sure you have the 64-bit version of sourceguardian installed, but on a 32-bit server.

Please download the 32-Bit version of the loader from here:
http://www.sourceguardian.com/loaders.html

Go on with this like you have described above. Sounds all good.

Best Regards,
Kai
ViMP Support Team
22.09.2014 15:54
 

Log in or register in order to write forum posts.

Inquiry
Inquiry
Demo