Support Center

ViMP Support

Support Forum

Avatar
mkh1202
Posts: 11
Debian
all transcoding had been updated

i try to upload the video and show this error
how can i fix this ?

QQ
30.11.2011 05:40
Avatar
mkh1202
Posts: 11
[Tue Nov 29 16:04:36 2011] [error] [client 10.190.240.184] [wrapped: SQLSTATE[HY000]: General error: 1267 Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '='], referer: http://10.190.240.147/media/upload
[Tue Nov 29 16:05:18 2011] [error] [client 10.190.240.184] [wrapped: SQLSTATE[HY000]: General error: 1267 Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '='], referer: http://10.190.240.147/media/upload
[Wed Nov 30 09:00:14 2011] [error] [client 10.190.240.184] [wrapped: SQLSTATE[HY000]: General error: 1267 Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '='], referer: http://10.190.240.133/media/upload
30.11.2011 07:29
Avatar
support
ViMP Support
Posts: 8611
Hello mkh1202,

that sounds like a wrong collation on the database.

We have a script to solve this.

Download the UTF-8 Charset Fix from http://www.vimp.com/en/download-fixes-patches.html, replace the database-name in the script and execute it on your database.

It´s most easy to to this with phpmyadmin. Choose your database there, oben the "SQL"-tab in copy the script into the textarea.

BTW: This error cannot appear after updating the transcoding software and even not if you update your MySQL-server.

Cheers,
ViMP Support Team
08.12.2011 15:30
Avatar
mkh1202
Posts: 11
i try , but still doesnt work .

and If html5 is disable transcoding will success .

what's that ?

i am using debian 6
18.01.2012 06:21
Avatar
support
ViMP Support
Posts: 8611
Hello mkh1202,

please note an extract of your logfiles like above again.
Should be another error now.

Cheers,
ViMP Support Team
19.01.2012 15:40
Avatar
mkh1202
Posts: 11
iconsupport:
Hello mkh1202,

please note an extract of your logfiles like above again.
Should be another error now.

Cheers,

how can i note my logfiles
i am linux rookie =/
20.01.2012 06:12
Avatar
support
ViMP Support
Posts: 8611
Hello mkh1202,

you find the transcoding-logfile in your ViMP-installationfolder as log/framework.convert.log

activate HTML5-player, restart transcoding of the medium and you will get status error, after the transcoding breaks.

You can open the framework.convert.log then and just post the last lines here (where you can see any error-messages.

If you´re in your ViMP-installation-folder, you can see the file growing with

# tail -f log/framework.convert.log

or you can show the last e.g. 200 lines with

# tail -n 200 log/framework.convert.log

Cheers,
ViMP Support Team
24.01.2012 23:42
Avatar
mkh1202
Posts: 11
>> chmod 775 /var/www/vimp/data/web/images/m...de56be2920961b3c_1326863141.flv
>> chown www-data.www-data /var/www/vimp/data/web/i...920961b3c_1326863141.flv
>> exec nice -n 19 "/usr/bin/ffmpeg" -i...de56be2920961b3c_1326863141.m4v
>> transcode + Problem executing command. (error 1)
[2012-01-26 09:07:02] {/var/www/vimp/data/scripts/sync_new_uploads.sh} stop
[2012-01-26 09:17:02] {/var/www/vimp/data/scripts/sync_new_uploads.sh} start
[2012-01-26 09:17:02] {/var/www/vimp/data/scripts/sync_new_uploads.sh} execute convert task
[2012-01-26 09:17:02] {/var/www/vimp/data/scripts/sync_new_uploads.sh} stop
26.01.2012 02:18
Avatar
support
ViMP Support
Posts: 8611
Hello mkh1202,

I think you did not copy the ffmpeg-presets. You can download them at
http://www.vimp.com/en/download-configurations.html

Put the extracted file to

/usr/share/ffmpag (if you have installed ffmpeg as packet)
/usr/local/share/ffmpeg (if you have compile ffmpeg yourself)

Cheers,
ViMP Support Team
28.01.2012 02:31
Avatar
mkh1202
Posts: 11
Solved

THX :)
31.01.2012 03:55
Avatar
drilld
Posts: 18
I have a similar problem, but coping the presents didnt fix it.
I get the same error.

iconCode:
jono@FTHSTREAM01:/media/mediastore/var/www/showvid/data$ sudo ./symfony framework:transcode
>> transcode media 5fb56fc95b025ef2cfc1d8c732be15e3 [573]
>> exec      "mplayer" -vo null -ao null -frames 0 -identify "/media/mediastore/var/www/showvid/data...2cfc1d8c732be15e3_1329523714.wmv" > "/tmp/info_output_5fb56fc95b025ef2cfc1d8c732be15e3"
>> exec      cat /tmp/info_output_5fb56fc95b025ef2cfc1d8c732be15e3 | grep ID_VIDEO_WIDTH
>> exec      cat /tmp/info_output_5fb56fc95b025ef2cfc1d8c732be15e3 | grep ID_VIDEO_HEIGHT
>> exec      cat /tmp/info_output_5fb56fc95b025ef2cfc1d8c732be15e3 | grep ID_LENGTH
>> file-     /tmp/info_output_5fb56fc95b025ef2cfc1d8c732be15e3
>> exec      mplayer -V | grep MPlayer
>> exec      nice -n 19 "mencoder" "/media/mediastore/var/www/showvid/data/web/images/source/5fb56fc...v:keyint=50:vbitrate=800:mbd=2:mv0:trell:v4mv:cbp:last_pred=3 -vf harddup,scale=320:240
>> chmod 775 /media/mediastore/var/www/showvid/data/web/images/media/5fb56fc95b025ef2cfc1d8c732be15e3_1329523714.flv
>> chown www-data.www-data /media/mediastore/var/www/showvid/data/web/images/media/5fb56fc95b025ef2cfc1d8c732be15e3_1329523714.flv
>> exec      nice -n 19 "ffmpeg" -i /media/mediastore/var/www/showvid/data/web/images/source/5fb56fc...e/var/www/showvid/data/web/images/media/5fb56fc95b025ef2cfc1d8c732be15e3_1329523714.m4v
>> transcode    + Problem executing command. (error 1)


however when i ran ffmpeg manually it works fine

iconCode:
sudo nice -n 19 "/usr/local/bin/ffmpeg" -i /media/mediastore/var/www/showvid/data/web/images/source/5fb56fc95b025ef2cfc1d8c732be15e3_1329523714.wmv /media/mediastore/var/www/showvid/data/web/images/media/5fb56fc95b025ef2cfc1d8c732be15e3_1329523714.m4v
18.02.2012 02:49
Avatar
support
ViMP Support
Posts: 8611
Hello drilld,

did you put the presets into /usr/local/share/ffmpeg and not /usr/share/ffmpeg ?

What distribution are you using?

What is the output, when you just type

# /usr/local/bin/ffmpeg

?

cheers,
ViMP Support Team
22.02.2012 15:46
Avatar
drilld
Posts: 18
distro: Ubuntu 10.10 x64
presets location: /usr/share/ffmpeg



/usr/local/bin/ffmpeg
iconCode:
ffmpeg version N-37985-gbfe7bac Copyright (c) 2000-2012 the FFmpeg developers
  built on Feb 18 2012 16:01:55 with gcc 4.4.5
  configuration: --enable-gpl --enable-version3 --enable-nonfree --enable-postpr                            oc --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libo                            pencore-amrwb --enable-libtheora --enable-libvorbis --enable-libvpx --enable-lib                            x264 --enable-libxvid --enable-x11grab
  libavutil      51. 39.100 / 51. 39.100
  libavcodec     54.  3.100 / 54.  3.100
  libavformat    54.  1.100 / 54.  1.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 62.101 /  2. 62.101
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0.  6.100 /  0.  6.100
  libpostproc    52.  0.100 / 52.  0.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfi                            le}...
[Last edited by drilld, 23.02.2012 04:12]
22.02.2012 23:46
Avatar
support
ViMP Support
Posts: 8611
Hello drilld,

I think the confusion results as you have installed ffmpeg at

/usr/bin/ffmpeg (as debian-package)

and at

/usr/local/bin/ffmpeg (self compiled)

We try with the self-compiled.

1. copy the presets to /usr/local/share/ffmpeg , too. (your listing is from /usr/share/ffmpeg)
2. change the path to ffmpeg in ViMP´s backend at administration -> configuration -> transcoder: path to ffmpeg: /usr/local/bin/ffmpeg

Then try again to transcode.

If this doesn´t work, post the output of the convert log nad we´ll see.

Cheers,
ViMP Support Team
28.02.2012 10:43
Avatar
drilld
Posts: 18
I had already copied the presets into: /usr/local/share/ffmpeg
just in case.

and the ffmpeg binaries are already pointing to:
/usr/local/bin/ffmpeg

thanks
Jono
28.02.2012 23:26

Log in or register in order to write forum posts.

Inquiry
Inquiry
Demo