Support Center

ViMP Support

System requirements for ViMP

  • You need a dedicated or virtual server with root permissions to install ViMP.
  • We recommend Linux as OS. An installation under UNIX, BSD or Windows is possible, but not officially supported.
  • We recommend to not use Plesk.
     

The following software is required to run ViMP

Apache2

  • Version 2.2 or 2.4 recommended
  • mod_rewrite must be enabled

PHP

  • Version 5.3.x, 5.4.x, 5.5.x, 5.6.x (as of ViMP 3.1.3)
  • GD library, Mcrypt, cURL, MySQL, mbstring, MySQLi, PDO, pdo_mysql and XSL extensions must be installed
  • PHP CLI (Command Line Interface) must be installed

MySQL

  • At least version 5.0
  • InnoDB must be installed

Transcoding
The transcoding tools should be installed exactly as described in the documentation. Due to patent protections it's not sufficient to install the default packages.

  • FFmpeg
  • additional codecs
     

Hardware

Our minimum recommendation is as follows:

  • Quad Core Processor or better
  • 8 GB RAM (better 16 GB or more)
  • 500 GB Hard disc space (the actual capacity needed depends on the number of media)

For additional data security, we recommend using a RAID controller.

Please note that the power of vServers can vary a lot, even if the above recommendations seem to be fulfilled. Thus we cannot give a general recommendation for virtual servers here.

Inquiry
Inquiry
Demo