Minimale Servervoraussetzungen für die Installation von ViMP:

Apache2

  • Version 2.4 empfohlen
  • mod_rewrite muss aktiviert sein

PHP

  • Version 5.5.x, 5.6.x, 7.0.x, 7.1.x, 7.2.x
  • GD-Bibliothek, openssl, cURL, MySQL, mbstring, time, MySQLi, PDO, pdo_mysql, npm und XSL-Erweiterungen müssen installiert sein
  • PHP CLI (Command Line Interface) muss installiert sein

MySQL/MariaDB

  • MySQL: Version 5.0 - 5.7
  • MariaDB: Mindestens Version 10.0
  • InnoDB muss installiert sein

 

Hardware

Als Mindestanforderung empfehlen wir:

  • Quad-Core-Prozessor oder besser
  • 8 GB RAM (besser 16 GB)
  • 500 GB Festplattenspeicher (die benötigte Größe hängt im Wesentlichen von der Medienzahl ab)

Wir empfehlen die Verwendung eines RAID-Controllers für zusätzliche Datensicherheit.