Support Center

ViMP Support

Support Forum

Avatar
support
ViMP Support
Posts: 8380
Hello drilld,

then post the output log/framework.convert.log of your last try here.

Cheers,
ViMP Support Team
29.02.2012 17:14
Avatar
drilld
Posts: 18
since nothings changed its still the same error:

29.02.2012 21:29
Avatar
support
ViMP Support
Posts: 8380
Hello drilld,

ok, then please post the output of ffmpeg.

Just write /usr/local/bin/ffmpeg in the shell and press return.
Post the output here then.

Cheers,
ViMP Support Team
05.03.2012 20:11
Avatar
support
ViMP Support
Posts: 8380
Hello drilld,

and you can tryout to remove the lines

iconCode:
directpred=3
flags2=+bpyramid+mixed_refs+wpred+dct8x8+fastpskip
wpredp=2


from the preset-file

/usr/local/share/ffmpeg/libx264-ipod640.ffpreset

Cheers,
ViMP Support Team
05.03.2012 21:10
Avatar
drilld
Posts: 18
my ipod640 preset doesnt look like that, ive re-downloaded the preset files to double check, mine looks like this:

iconCode:
jono@FTHSTREAM01:~$ tail /home/jono/libx264-ipod640.ffpreset
coder=0
bf=0
refs=1
flags2=-wpred-dct8x8
level=30
maxrate=10000000
bufsize=10000000
wpredp=0
jono@FTHSTREAM01:~$


and after the change, I took out the lines requested that were present, it now looks like this:

iconCode:
jono@FTHSTREAM01:~$ tail /usr/local/share/ffmpeg/libx264-ipod640.ffpreset
coder=0
bf=0
refs=1
level=30
maxrate=10000000
bufsize=10000000


yet I still get the transcoding error
[Last edited by drilld, 06.03.2012 02:45]
06.03.2012 02:44
Avatar
support
ViMP Support
Posts: 8380
Hello drilld,

yes, I was wrong. ok.
But do the same in libx264-slow.ffpreset , too.

But you forgot my next above post:

iconQuote:

Hello drilld,

ok, then please post the output of ffmpeg.

Just write /usr/local/bin/ffmpeg in the shell and press return.
Post the output here then.

Cheers,


Cheers,
ViMP Support Team
06.03.2012 19:51
Avatar
drilld
Posts: 18
iconCode:
jono@FTHSTREAM01:/$ /usr/local/bin/ffmpeg
ffmpeg version N-37985-gbfe7bac Copyright (c) 2000-2012 the FFmpeg developers
  built on Feb 18 2012 16:01:55 with gcc 4.4.5
  configuration: --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab
  libavutil      51. 39.100 / 51. 39.100
  libavcodec     54.  3.100 / 54.  3.100
  libavformat    54.  1.100 / 54.  1.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 62.101 /  2. 62.101
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0.  6.100 /  0.  6.100
  libpostproc    52.  0.100 / 52.  0.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'
jono@FTHSTREAM01:/$
08.03.2012 03:57
Avatar
drilld
Posts: 18
after taking the lines out of libx264-slow.ffpreset

we now get error 127:

iconCode:
[2012-03-09 12:14:01] {/media/mediastore/var/www/showvid/data/scripts/sync_new_uploads.sh} execute convert task
>> transcode media 87d77c5efdb890b4fdc86cfbf1a6bd36 [579]
>> exec      "mplayer" -vo null -ao null -fr...d77c5efdb890b4fdc86cfbf1a6bd36"
>> exec      cat /tmp/info_output_87d77c5efd...bf1a6bd36 | grep ID_VIDEO_WIDTH
>> exec      cat /tmp/info_output_87d77c5efd...f1a6bd36 | grep ID_VIDEO_HEIGHT
>> exec      cat /tmp/info_output_87d77c5efd...c86cfbf1a6bd36 | grep ID_LENGTH
>> file-     /tmp/info_output_87d77c5efdb890b4fdc86cfbf1a6bd36
>> exec      mplayer -V | grep MPlayer
>> exec      nice -n 19 "mencoder" "/media/m...red=3 -vf harddup,scale=320:240
[2012-03-09 12:15:01] {/media/mediastore/var/www/showvid/data/scripts/sync_new_uploads.sh} start
[2012-03-09 12:15:01] {/media/mediastore/var/www/showvid/data/scripts/sync_new_uploads.sh} is already running [17790]
>> chmod 775 /media/mediastore/var/www/showv...fdc86cfbf1a6bd36_1330980400.flv
>> chown www-data.www-data /media/mediastore/var/ww...bf1a6bd36_1330980400.flv
>> exec      nice -n 19 "/usr/local/bin/ffmp...fdc86cfbf1a6bd36_1330980400.m4v
[2012-03-09 12:16:01] {/media/mediastore/var/www/showvid/data/scripts/sync_new_uploads.sh} start
[2012-03-09 12:16:01] {/media/mediastore/var/www/showvid/data/scripts/sync_new_uploads.sh} is already running [17790]
>> exec      "/media/mediastore/var/www/show...0.m4v" "/tmp/4f593db4740c7.mp4"
>> transcode    + Problem executing command. (error 127)
[2012-03-09 12:14:01] {/media/mediastore/var/www/showvid/data/scripts/sync_new_uploads.sh} stop
09.03.2012 00:58
Avatar
support
ViMP Support
Posts: 8380
Hello drilld,

please check your mailbox.

Cheers,
ViMP Support Team
09.03.2012 12:42
Avatar
support
ViMP Support
Posts: 8380
Hello,

please check out the following article when error 127 occurs in the log/framework.convert.log:
http://www.vimp.com/en/documentation-faq-article/items/problem-executing-command-error-127-209.html

Regards,
ViMP Support Team
21.03.2012 19:40
Avatar
drilld
Posts: 18
didnt help. followed all steps, removed ruby, installed new ruby etc. still got error 127

still also go slow page loads, due to SQL query: http://www.vimp.com/en/forum/topic/1310.html

also getting this error in my framework.convert.log:

iconCode:
[2012-03-28 11:22:01] {/media/mediastore/var/www/showvid/data/scripts/sync_new_uploads.sh} start
[2012-03-28 11:22:01] {/media/mediastore/var/www/showvid/data/scripts/sync_new_uploads.sh} execute convert task
>> transcode media cb17b9fa5d7f75b87d356d806c16698e [593]
>> transcode    + move bbb15ab57dfa389bbdadf...c4194ec37789e2375e51acccc7d.wmv
>> rename    /media/mediastore/var/www/showv...7d356d806c16698e_1332886905.wmv
>> chmod 775 /media/mediastore/var/www/showv...7d356d806c16698e_1332886905.wmv
>> chown www-data.www-data /media/mediastore/var/ww...06c16698e_1332886905.wmv
>> exec      "mplayer" -vo null -ao null -fr...17b9fa5d7f75b87d356d806c16698e"
>> exec      cat /tmp/info_output_cb17b9fa5d...06c16698e | grep ID_VIDEO_WIDTH
>> exec      cat /tmp/info_output_cb17b9fa5d...6c16698e | grep ID_VIDEO_HEIGHT
>> exec      cat /tmp/info_output_cb17b9fa5d...356d806c16698e | grep ID_LENGTH
>> file-     /tmp/info_output_cb17b9fa5d7f75b87d356d806c16698e
>> exec      mplayer -V | grep MPlayer
>> exec      nice -n 19 "mencoder" "/media/m...red=3 -vf harddup,scale=360:288
>> chmod 775 /media/mediastore/var/www/showv...7d356d806c16698e_1332886905.flv
>> chown www-data.www-data /media/mediastore/var/ww...06c16698e_1332886905.flv
>> exec      nice -n 19 "/usr/local/bin/ffmp...7d356d806c16698e_1332886905.m4v
>> exec      "/media/mediastore/var/www/show...5.m4v" "/tmp/4f723daba7540.mp4"
>> transcode    + Problem executing command. (error 127)

                                                                                                                                 
  Unable to execute UPDATE statement. [wrapped: SQLSTATE[HY000]: General error: 1206 The total number of locks exceeds the lock table size]
[Last edited by drilld, 28.03.2012 00:23]
27.03.2012 23:02
Avatar
mattdasplat
Posts: 4
Hi

I am having the same problems as drilld. I am running ubuntu 11.10 32-bit, and vimp 2.5.2-r19859. I recieved 'error 1' whenever trying to transcode videos when enable HTML5 player was enabled.

I followed all of the instructions, and compiled ffmpeg, modified the presets and then recieved 'error 127'. I then installed ruby 1.8.6 & flvtool2-1.0.6 but still recieve 'error 127'. The only fix is still to disable HTML5 player, but we need m4v for ipad playback etc.

Is there any more troubleshooting steps you could give me? I notice others are having the same problems on the forums.

Thanks

Matt
19.04.2012 06:18
Avatar
support
ViMP Support
Posts: 8380
Hello,

please check this article:
http://rackerhacker.com/2010/02/16/mysql-the-total-number-of-locks-exceeds-the-lock-table-size-2/

And please install ffmpeg 0.8.10 or 0.7.12 like here described:
http://www.vimp.com/dokumentation-faq-artikel/items/ubuntu-debian-ffmpeg-selbst-kompilieren.html

@mattdasplat: If you don´t have exactly the same problem or if you´re not sure, please open an own thread, thx.

cheers,
ViMP Support Team
19.04.2012 12:48
Avatar
mattdasplat
Posts: 4
Hi

Thanks for your reponse. I am trying to troubleshoot this with drilld (he is a colleague). I built my own VM to try and rule out everything else, including trying the latest version of Ubuntu, and the latest version of vimp at the time of downloading (3 weeks ago).

I have already completed all steps in the ffmpeg for both 0.8.10 and 0.7.12 article you have linked to with no success. I am not having the same SQL lock issue that drilld had in his build.

Here is an example of the error in framework.convert.log

iconCode:
>> transcode media 76ab9fa3e4855073d6e49073a5124cea [6]
>> exec      "mplayer" -vo null -ao null -fr...ab9fa3e4855073d6e49073a5124cea"
>> exec      cat /tmp/info_output_76ab9fa3e4...3a5124cea | grep ID_VIDEO_WIDTH
>> exec      cat /tmp/info_output_76ab9fa3e4...a5124cea | grep ID_VIDEO_HEIGHT
>> exec      cat /tmp/info_output_76ab9fa3e4...e49073a5124cea | grep ID_LENGTH
>> file-     /tmp/info_output_76ab9fa3e4855073d6e49073a5124cea
>> exec      mplayer -V | grep MPlayer
>> exec      nice -n 19 "mencoder" "/var/www...red=3 -vf harddup,scale=720:406
>> chmod 775 /var/www/web/images/media/76ab9...d6e49073a5124cea_1334720210.flv
>> chown www-data.www-data /var/www/web/images/medi...3a5124cea_1334720210.flv
>> exec      nice -n 19 "/usr/local/bin/ffmp...d6e49073a5124cea_1334720210.m4v
[2012-04-20 12:06:01] {/var/www/scripts/sync_new_uploads.sh} start
[2012-04-20 12:06:01] {/var/www/scripts/sync_new_uploads.sh} is already running [2319]
>> exec      "qt-faststart" "/var/www/web/im...0.m4v" "/tmp/4f90a8836de20.mp4"
>> transcode    + Problem executing command. (error 127)
20.04.2012 02:10
Avatar
support
ViMP Support
Posts: 8380
Hello mattdasplat,

I think qt-faststart ist not installed.

Check in the shell what

# which qt-faststart

says. If you´re shown a path, insert it at administration -> configuration -> transcoder: path to qt-faststart

If not, you can download qt-faststart here:
http://www.vimp.com/download-konfigurationen.html

Cheers,
ViMP Support Team
21.04.2012 10:43

Log in or register in order to write forum posts.

Inquiry
Inquiry
Demo